!!! Ayuda, Dudas y Problemas de montaje.

Toda la información relacionada con el DisplayXR.

Moderador: XRStaff

Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 15 Jul 2009 21:21

Hola a todos,

Pues después de montar mi kit XR, veo que hace el testeo bien, pero al llegar a los 5 leds azules, éstos se encienden muy levemente, vamos, que si no está la habitación a oscuras no se ven, cosa que no pasa con los otros; no sé si puede ser problema de comunicación con la placa de control. Si a alguien le ha pasado algo similar le agradecería un comentario, aunque me he repasado casi todas las páginas del nuevo hilo dedicado a problemas y no he visto nada similar.

Gracias y saludos
Avatar de Usuario
crobol
Maestro al volante
Maestro al volante
Donante
Donante
Licencia B
Licencia B
Mensajes: 13867
Registrado: 28 Abr 2007 00:00
Volante: DFP
Ubicación: BCN
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por crobol » 15 Jul 2009 21:29

Orale, los leds azules de los laterales tambien?
A ver si son diferentes al resto y exigen mas Intensidad... :dry:
Avatar de Usuario
tosti
Admin
Admin
Donante
Donante
Licencia B
Licencia B
Mensajes: 2511
Registrado: 03 May 2005 00:00
Volante: Logitech G25
Ubicación: Euskal Herria
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por tosti » 15 Jul 2009 21:45

lukiluc24, como bien te han dicho hay que tener cuidado con lo que se dice. Esto es un trabajo serio que varias personas nos han regalado y el cual debemos de respetar. Tu post no me habia sentado mal, pero si que es un poco desentonante, por mi parte no hay ningun problema y doy el tema por zanjado.

Ten paciencia y no busques soluciones desesperadas, cuando pueda posteare lo prometido y podras empezar a hacer comprobaciones.

:chao:
Saludos,
tosti
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 15 Jul 2009 21:50

crobol escribió:Orale, los leds azules de los laterales tambien?
A ver si son diferentes al resto y exigen mas Intensidad... :dry:
No crobol,

Sólo los 5 de arriba, y son todos en principio iguales, comprados allí en gran vía, ya sabes...
Avatar de Usuario
lukiluc24
Mecánico de Pista
Mecánico de Pista
Mensajes: 32
Registrado: 30 Oct 2006 01:00
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por lukiluc24 » 15 Jul 2009 21:54

tosti te decia eso de otra placa de esas continuas, porque si estan conectadas las pistas poco se puede hacer, no?
Avatar de Usuario
Nye
Primera conducción sin ayudas
Primera conducción sin ayudas
Mensajes: 398
Registrado: 16 Dic 2008 01:00
Volante: G25
Ubicación: Sabadell
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Nye » 15 Jul 2009 22:05

Depende de la situación y de lo fino que sea tu pulso. Podrias cortar esas pistas 'chungas' con un cutter por ejemplo, para luego rehacerlas con puentes desde el origen hasta el destino (no se si me explico muy bien).
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 15 Jul 2009 22:10

Bueno, pues me crecen los enanos... :llorar:

Un compañero que acaba de montar su display XR, tiene problemas con el reconocimiento de éste en windows xp. En ese mismo equipo es donde yo he probado el mío y ha aparecido el problema de los 5 leds azules de las rpm. A él le sale el mensaje de xtreme racers en los displays, pero ni asomo de "nuevo hardware encontrado..etc". En páginas anteriores, cuando Gaboni empezaba a testear su kit, me pareció entender que el que se encendiesen los displays con el mensaje, indicaba tan solo que el pic estaba correctamente programado, por lo que, viendo que a algunas personas del foro le ha pasado algo similar, ¿podría ser un problema del conector USB? creeis recomendable quitar el conector para probar con cables directamente?

Gracias por leeros el tocho, :faint: cualquier sugerencia, como siempre, bienvenida.

Saludos
Avatar de Usuario
tosti
Admin
Admin
Donante
Donante
Licencia B
Licencia B
Mensajes: 2511
Registrado: 03 May 2005 00:00
Volante: Logitech G25
Ubicación: Euskal Herria
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por tosti » 15 Jul 2009 22:25

lukiluc24 escribió:tosti te decia eso de otra placa de esas continuas, porque si estan conectadas las pistas poco se puede hacer, no?
Antes de buscar soluciones, lo primero que hay que hacer es detectar el problema. Si todavia no sabemos si tienes una pista rota o dos pistas deribadas, ¿como quieres empezar a solucionarlo?

Por favor, ten paciencia y espera.
Saludos,
tosti
Avatar de Usuario
Nye
Primera conducción sin ayudas
Primera conducción sin ayudas
Mensajes: 398
Registrado: 16 Dic 2008 01:00
Volante: G25
Ubicación: Sabadell
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Nye » 15 Jul 2009 23:44

orale escribió:Bueno, pues me crecen los enanos... :llorar:

Un compañero que acaba de montar su display XR, tiene problemas con el reconocimiento de éste en windows xp. En ese mismo equipo es donde yo he probado el mío y ha aparecido el problema de los 5 leds azules de las rpm. A él le sale el mensaje de xtreme racers en los displays, pero ni asomo de "nuevo hardware encontrado..etc". En páginas anteriores, cuando Gaboni empezaba a testear su kit, me pareció entender que el que se encendiesen los displays con el mensaje, indicaba tan solo que el pic estaba correctamente programado, por lo que, viendo que a algunas personas del foro le ha pasado algo similar, ¿podría ser un problema del conector USB? creeis recomendable quitar el conector para probar con cables directamente?

Gracias por leeros el tocho, :faint: cualquier sugerencia, como siempre, bienvenida.

Saludos
Lo que yo puedo contarte:

Parte 1: El hecho de que te muestre el mensaje cuando lo enchufas al puerto USB solo corrobora que al display le llega alimentación del puerto USB y que, en principio, el montaje/soldadura de los displays de 7 segmentos y las conexiones entre placa de control y de displays son correctas. No todas se testean, pero si no te enciende leds y el mensaje se puede leer correctamente ya es buen indicador. Ademas corrobora que el PIC tiene la programación correcta. Pero no te indica nada sobre la comunicación entre el PC y el Display.

Parte 2: Luego está el tema del reconocimiento del dispositivo por parte del sistema operativo como un nuevo controlador de juegos. Esa parte por lo visto da problemas en segun que configuraciones de sistema operativo o caracteristicas/peculiaridades de la instalación del mismo. Ese reconocimiento por parte del sistema solamente es necesario en caso de que se vayan a utilizar las entradas del display, como son las dos analógicas de los potenciómetros o los botones y conmutadores (no todos los conmutadores, ya que los dos primeros estan reservados al uso interno del display para variar algunos de sus parametros).

Parte 3: Por ultimo está la comunicación con los programas que mandan datos al display para que los muestre, y en algunos casos reciben información del mismo. El programa test de Gaboni y el PD Display 2.
Esta comunicación está gestionada por la libreria mchid.dll y no necesita para nada que el dispositivo esté reconocido por el sistema operativo como controlador de juegos.


La primera parte te indica que el hard está bien.
La segunda parte (y la mas problematica por lo visto) te permite meter botones y ejes al display para usarlos directamente desde los juegos.
La tercera parte es la que gestiona el envio de datos de los juegos hacia el display para mostrar los datos en el.


Disculpadme si no doy ninguna solución al problema. Si supiera que es lo que ocurre os lo contaria sin falta. Pero por lo menos queria dejar claros los conceptos porque os pueden ayudar a manejar mejor esos problemas.

Saludos
Avatar de Usuario
acaymo
Espectador
Espectador
Mensajes: 11
Registrado: 01 May 2006 00:00

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por acaymo » 16 Jul 2009 13:24

Buenas, he conectado 10 botones al display utilizando diodos 1N4007 en vez de los sugeridos por vosotros (1N4148), los botones me funcionan y todo parece correcto y el tipo de la tienda me dijo que es lo mismo uno que otro, ¿es cierto? ¿corro algún riesgo utilizando estos?

Gracias.

Saludos.
Avatar de Usuario
BEDI
Piloto Histórico
Piloto Histórico
Licencia B
Licencia B
Mensajes: 1468
Registrado: 16 Sep 2007 00:00

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por BEDI » 16 Jul 2009 15:04

El 1N4148 por sus especificaciones esta más orientado a electrónica para este tipo de circuitos modestos. El 1N4007 soporta mas intensidad, mayor tensión inversa y es más lento.

Pero baia, no debes tener ningún problema con ese.
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 16 Jul 2009 20:00

Nye escribió:Ese reconocimiento por parte del sistema solamente es necesario en caso de que se vayan a utilizar las entradas del display...

Parte 3: Por ultimo está la comunicación con los programas que mandan datos al display para que los muestre, y en algunos casos reciben información del mismo. El programa test de Gaboni y el PD Display 2.
Esta comunicación está gestionada por la libreria mchid.dll y no necesita para nada que el dispositivo esté reconocido por el sistema operativo como controlador de juegos.


Hola Nye y gracias por tus aclaraciones. No se si lo he entendido mal, pero creo interpretar que aunque el PC no reconociera la placa de control del kit, en principio, éste debería funcionar? Aunque también te diré que tampoco hacía el testeo con el PD Display 2.

En cualquier caso, gracias de nuevo por tu interés, pero hoy he probado a soldar los cables USB directos a la placa y tampoco, con lo que mi esperanza de que fuera el conector se ha desvanecido. Realmente, no hay mucha opción para el error, ya que en ésta placa es poco lo que hay que soldar, pero si a alguien se le ocurre alguna cosa que pudiera interferir, le agradecería el comentario.

Un saludo
Última edición por orale el 16 Jul 2009 22:12, editado 2 veces en total.
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 16 Jul 2009 20:25

Hola a todos,

De nuevo me dirijo a éste foro para solicitar un SOS desesperado. Aprovecho la oportunidad que me brinda el mismo para pedir, por favor, si alguien sería tan amable de echarle un vistazo a mis placas, ya que mis conocimientos para ello son nulos. Huelga decir que yo correría con los gastos de envío y devolución a mi domicilio, incluso entendería que alguien valorase su trabajo en una cantidad que se podría hablar sin ningún problema. No son buenas fechas para ello, con las vacaciones a la vuelta de la esquina, pero ya me da igual; entended que después de 6-7 meses siguiendo el hilo dedicado a diario, cuando por fin tengo el kit en mi poder, no puedo disfrutar de él. Tan sólo espero no violar ninguna norma del foro con la solicitud.

Un saludo
Avatar de Usuario
crobol
Maestro al volante
Maestro al volante
Donante
Donante
Licencia B
Licencia B
Mensajes: 13867
Registrado: 28 Abr 2007 00:00
Volante: DFP
Ubicación: BCN
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por crobol » 16 Jul 2009 20:59

orale escribió:Tan sólo espero no violar ninguna norma del foro con la solicitud.
Tranquilo con eso. Alguna solución encontraremos, no desesperes.
Avatar de Usuario
Fotero1
Mecánico de Pista
Mecánico de Pista
Mensajes: 33
Registrado: 26 Sep 2008 00:00

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Fotero1 » 17 Jul 2009 07:49

He estado leyendo desde el principio y lo voy a pasar mal de cojones con esto xddd :cabezazos: :cabezazos: :cabezazos: :cabezazos: , yo en mi vida hasta estos dos días ultimos había visto nada relacionado con electronica, diodos, conmutadores, encoders, conexiones, en fin que igual entenderia mejor a un chino que todo esto. A veremos como queda el tema.
Gracias por todo lo aquí expuesto, pero... lo voy a tener crudo. :oops: :oops:
Avatar de Usuario
crobol
Maestro al volante
Maestro al volante
Donante
Donante
Licencia B
Licencia B
Mensajes: 13867
Registrado: 28 Abr 2007 00:00
Volante: DFP
Ubicación: BCN
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por crobol » 17 Jul 2009 13:36

Orale, releyendo tus post anteriores no me ha quedado claro cual es tu problema. No se si es lo de los leds azules que no lucen o que el XP no reconoce tu dispositivo.

Por lo que entiendo de tus mensajes, no creo que sea problema del conector USB.

En XP no siempre sale un mensaje de "Nuevo hardware encontrado" y esas cosas, a mi nunca me sale. Para verificar que el sistema reconoce el dispositivo puedes ir a Inicio/Configuración/Panel de Control/Dispositivos de Juego

¿Os aparece el dispositivo en el menu "Dispositivos de Juego" del XP?
¿Os hace a los 2 el test de inicio con el saludo?
¿Habéis probado tu amigo y tu el software de test de Gaboni para testar cada led y digito?
¿Habéis rodado con algún simulador y el display?
Avatar de Usuario
TrikiTriki
Mecánico de Pista
Mecánico de Pista
Mensajes: 38
Registrado: 14 Feb 2009 01:00
Volante: Logitech G25

Re: Desarrollo Display XR SimRacing (DIY)

Mensaje por TrikiTriki » 17 Jul 2009 16:42

crobol escribió:
BEDI escribió:he detectado un comportamiento extraño de un LED. Concretamente el 7º empezando por la izquierda.Supongo que no es algo general.
A mi me pasa igual, será una consecuencia del funcionamiento sin mas consecuencias.
Bueno por fin he armao el Invento! perfecto todo excepto por lo que comentaron algunos foreros, el 7º led se ve una luz tenua, pero he investigado un poco mas y solo me aparece cuando la marcha metida, el numero usa el segmento del centro, y luego en 6a y 7a el led y 2 y 3 también se me encienden con una luz muy tenue cuando no deberian, esto es por alguna causa hardware? software?

edito:bueno voy editando de mas cosas que me he fijado.
Hay varios leds que le pasan lo mismo, que cuando deberian estar apagaos, y coincide que alguna parte de un display de los pequeños se enciende, pues el led tmb se enciende minimamente, caso del led rojo de las banderas de la derecha. Y luego el display pequeño a la derecha del grande, tiene menos intensidad que el resto, siendo todos el mismo modelo.

Par ser mas aclarativo, que me lio un poco, pongo un video.

[youtube][/youtube]

Un saludo compañeros y felicitar de nuevo a toda la comunidad y en especial a Gabony/Nye/Calvorota.

PD: tengo windows vista 64 y no ha detectado todo correctamente, pero no me aparece en controlador de dispositivos.
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 17 Jul 2009 19:10

crobol escribió:Orale, releyendo tus post anteriores no me ha quedado claro cual es tu problema. No se si es lo de los leds azules que no lucen o que el XP no reconoce tu dispositivo.

Por lo que entiendo de tus mensajes, no creo que sea problema del conector USB.

En XP no siempre sale un mensaje de "Nuevo hardware encontrado" y esas cosas, a mi nunca me sale. Para verificar que el sistema reconoce el dispositivo puedes ir a Inicio/Configuración/Panel de Control/Dispositivos de Juego

¿Os aparece el dispositivo en el menu "Dispositivos de Juego" del XP?
¿Os hace a los 2 el test de inicio con el saludo?
¿Habéis probado tu amigo y tu el software de test de Gaboni para testar cada led y digito?
¿Habéis rodado con algún simulador y el display?
Hola Crobol,

Gracias por tu interés. Si, la verdad es que he ido posteando mis dudas un poco desordenadamente. Por un lado, de los 2 kits, Hay uno que funciona perfecto, funciona bien con rfactor, que es el único que hemos probado, con la salvedad que los 5 últimos leds azules, al hacer el testeo con el soft de Nye casi no se ven, por lo demás, el ordenador reconoce el dispositivo como "dispositivo de juegos, etc".

Por otro lado, tenemos el otro que el ordenador no reconoce nada, ni sale lo de dispositivo de juegos, ni hace el testeo con el soft de Nye, tan solo muestra brevemente el mensaje de bienvenida de "Extremeracers" durante unos segundos.

Nos faltaría probar el soft de Gaboni, pero no entiendo muy bien como va, no tengo claro si debo copiar la libreria que adjunta, o con la que grabé del soft de Nye es suficiente.

Un saludo y gracias de nuevo por la ayuda :wink:
Avatar de Usuario
crobol
Maestro al volante
Maestro al volante
Donante
Donante
Licencia B
Licencia B
Mensajes: 13867
Registrado: 28 Abr 2007 00:00
Volante: DFP
Ubicación: BCN
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por crobol » 17 Jul 2009 19:26

orale escribió:Nos faltaría probar el soft de Gaboni, pero no entiendo muy bien como va, no tengo claro si debo copiar la libreria que adjunta, o con la que grabé del soft de Nye es suficiente.
Copia mcHID.dll a tu carpeta windowssystem32. Si ya lo hiciste con el PDdisplay, no debería hacer falta.

rFtestvisu2.exe
Imagen

Ejecutas el rFvisu2.exe y para testar cada led lo seleccionas y los digitos escribes números en los espacios. Le das a enviar y veras como responde el display durante unos segundos repitiendo lo que has especificado.

Lo de los leds azules que no lucen, no te queda otra que determinar el fallo por descarte. Lo 1ro seria sacar uno de esos les y probar otro, a ver si están al revés o son defectuosos, aunque los 5 parece mucha casualidad.
Quizás un tema de cableado...
Avatar de Usuario
Nye
Primera conducción sin ayudas
Primera conducción sin ayudas
Mensajes: 398
Registrado: 16 Dic 2008 01:00
Volante: G25
Ubicación: Sabadell
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Nye » 17 Jul 2009 19:47

crobol escribió:Copia mcHID.dll a tu carpeta windowssystem32. Si ya lo hiciste con el PDdisplay, no debería hacer falta.
'Sastamente'.

La libreria utilizada es la misma. Ambos programas la utilizan para comunicarse con el display y cualquiera de ellas que copies a System32 valdrá para los dos.
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 17 Jul 2009 20:08

Crobol,

La placa de control y la de display están conectadas con pins macho en una y hembra en otra, ya que la altura daba sin tocar los componentes de una placa con la otra. Puede ser que éste tipo de conexión no sea muy fiable?
Avatar de Usuario
Nye
Primera conducción sin ayudas
Primera conducción sin ayudas
Mensajes: 398
Registrado: 16 Dic 2008 01:00
Volante: G25
Ubicación: Sabadell
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Nye » 17 Jul 2009 20:21

Si por lo que leo tienes la posibilidad de separar las placas de forma facil, y si no lo has probado ya.... Separalas y prueba la de control. Aunque la de displays no esté conectada la de control deberia de comunicarse con el PC, ser reconocida como dispositivo de juegos y mostrarte que está conectada tanto en el Test de Gaboni como en el PD Display 2. Eso te ayudaria a determinar si habeis cometido algun fallo en la de displays, o si desafortunadamente la de control ha 'muerto'.


Editado: Para no mezclar las cosas.... estoy hablando de la que aparentemente no funciona, no la del problema con los leds.
Avatar de Usuario
orale
Recien salido a pista
Recien salido a pista
Mensajes: 68
Registrado: 30 Mar 2008 01:00
Volante: G25
Ubicación: Hospitalet
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por orale » 17 Jul 2009 20:25

Nye escribió:Si por lo que leo tienes la posibilidad de separar las placas de forma facil, y si no lo has probado ya.... Separalas y prueba la de control. Aunque la de displays no esté conectada la de control deberia de comunicarse con el PC, ser reconocida como dispositivo de juegos y mostrarte que está conectada tanto en el Test de Gaboni como en el PD Display 2. Eso te ayudaria a determinar si habeis cometido algun fallo en la de displays, o si desafortunadamente la de control ha 'muerto'.
Nye,

Como bien dices, ya probamos la de control por separado, y no la reconoce el PC. Eso es señal de "muerte"?. No digo que no sea posible ni mucho menos, pero precisamente, esa placa es la que menos "trasteo" lleva, ya que tan solo se conectó el USB y la tira de pines
Avatar de Usuario
Nye
Primera conducción sin ayudas
Primera conducción sin ayudas
Mensajes: 398
Registrado: 16 Dic 2008 01:00
Volante: G25
Ubicación: Sabadell
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por Nye » 17 Jul 2009 22:01

Pues mal pinta, la verdad.
Aunque yo en vuestro lugar intentaria revisar el conector USB y las salidas hacia los pines de interconexion de las dos placas. Esta ultima parte, si me apuras, incluso la desoldaria para descartar que haya un cortocircuito en esas soldaduras.
Si tras realizar esta operación todavia sigue sin dar señales de querer conectarse, entonces me temo que algo está realmente mal.

El PIC, o no está dañado, o por lo menos no lo está del todo, ya que al recibir tensión cobra vida al mostrarte el mensaje de xtremeracers.
Si aun así no parece comunicarse con el PC, entonces se me ocurre que pueda haber algun problema con las pistas que llevan los datos del USB al PIC: D+ y D-. Yo intentaria seguir esas pistas con un 'tester' para ver si llegan a su destino en las patas correctas del PIC (saca el PIC del zócalo por si acaso).

Si tras intentar todo esto, sigue sin funcionar, entonces ya no se que mas decirte. Podria ser que el PIC esté dañado y tenga problemas en el patillaje de comunicación, o puede incluso que el programa no esté grabado adecuadamente,... o quien sabe. Ahi yo no puedo ayudarte mucho. Quizas alguien que conozca mejor el tema de los PICS pueda darte algun consejo antes de tirar la toalla definitivamente.
Avatar de Usuario
pflanzgarten
Recien salido a pista
Recien salido a pista
Mensajes: 97
Registrado: 12 Ene 2009 01:00
Volante: Logitech Formula Force GP
Ubicación: Madrid
Contactar:

Re: DisplayXR - Ayuda, Dudas y Problemas

Mensaje por pflanzgarten » 20 Jul 2009 10:49

Hola...

Tengo un Display XR en mi poder, y unos consejos para los que no estéis acostumbrados a soldar o no hayáis soldado en vuestra vida:

Usad esto para inter-conectar las dos placas:

[img]http://www.foroselectronica.es/attachme ... -pines.jpg[/img]

Para conectar el circuito al PC "USAD EL CONECTOR USB" y olvidaros de conectar el cable directamente.

y además...

Si no me ha parecido mal, la placa base lleva dos planos de masa, el positivo por un lado, y el negativo por el otro. Lo de los planos de masa en circuitos eminentemente digitales, en principio, no es necesario, pero bueno, Calvorota lo ha decidido así, y ya está. El caso es que los PADs, que es como se llaman los redondelillos donde se suelda, en la mayor parte de los casos, tiene los planos de masa MUY CERCA, y en cuanto se eche un poquito de estaño de más, existe una gran cantidad de posibilidades de hacer un cortocircuito con ese PIN.

OJO!! que no estoy criticando al circuito impreso, solo os aviso para que los que tengáis menos experiencia soldando componentes tengáis extremo cuidado al soldar. El circuito está hecho de puta madre, pero tiene dos o tres soldaduras/dessoldaduras de vida... después se empezarán despegar los PADs y a cortar las pistas.

Gabo, ¿que tal llevas la versión del HEX pública?. El PIC de la placa que me han pasado tiene el módulo USB quemado (probado empíricamente :blush: ). Aunque no lo he probado en el display porque, de momento, no voy a soldar las tiras de pines, creo que el resto del micro funciona puesto que me lo reconoce el programador, aunque, como es lógico, me devuelve ceros.

Disculpad si he sido demasiado alarmista, pero es que, aunque las placas son una maravilla, creo que son demasiado frágiles para gente que no este muy puesta en soldar componentes.
Responder